n2guard is necessary